Qlik Community

QlikView Administration

Discussion Board for collaboration on QlikView Management.

cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

AJAXZfc on QVS v10 and QVS v8.5

Hi Folks,

 

I'm facing the next problem.

 

If I call my report on my QlikView 10 Server with the next URL  http://server/qvajaxzfc/opendoc.htm?document=apps/Cadenas_Pest.qvw Its works perfect, but if I call it using the same URL but using my QlikView Server 8.5 it doesn't work.

 

Exist a diferent way to call a qvw using AJAXzfc on version 8.5 or on version 10???

 

Thanks in advance.

11 Replies
Not applicable
Author

Hello adumd,

                     I hope there is little bit changes are there, becaue Qlikview 8.5 works on IIS Server but 9 onwards it works on either Qlikview Webserver or IIS  and what type of error your getting.

Regards,

Ravi.

Not applicable
Author

Hi ravietchno,

On QlikView 10 inside my network, the app works perfect, but outside my network, I'm getting a "Failed Authentication" message. On QlikView 8.5 I just getting the message "Page cannot be found".

Thanks for any directions!

tabletuner
Creator III
Creator III

In which qlikview version was the application reloaded? 10 or 8.5?

And in v10 you need to create custom users for users outside your network domain because NTFS cant authorize the users. DMS is required too.

Regards,

Tjeerd Wieberdink

Not applicable
Author

Thanks. Well I do have 2 qvw. One for 8.5 and other for 10. Both qvw have Access Security applied. Both works perfect under QvPlugin call. But the problem is under AjaxZfc way.

tabletuner
Creator III
Creator III

i recall that in 8.5 you had to manually build the AJAXZFC in developer modus and publish it.

in v10 it is automatically created for you without extra effort.

Can you also check port 80?

Not applicable
Author

Meanwhile I keep trying to have this done. It seems to me that every time (in version 8.5) I refresh the qvw I will need to create the AjaxZfc web page again. I'm right??

danielrozental
Master II
Master II

Why are you trying to access an application in a QV8.5 Server?

Do you need the 8.5 application to be available in Ajax? that's probably not a great idea unless your app is quite simple.

Not applicable
Author

My production environment is still on 8.5 and I'm trying to gain performance, due to a important customer do not have a good internet connection and using QvPlugin sometimes give us a time out connection.

danielrozental
Master II
Master II

The URL in your first post will only work for QV10, I don't remember how the URL was for QV 8.5, you should try to find that out.