Skip to main content
Qlik Introduces a New Era of Visualization! READ ALL ABOUT IT
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Issue reloading documents via Publisher which reads data from sharepoint list

I am  getting data from a SharePoint list in the form of xml (via owssrv.dll RPC ). We are able to reload from the user who created the script. But the Reload fails in Publisher with error message access denied. We have public access to the source SharePoint site hence the service account should also have.

If Someone else try to reload the data, It also gives Access denied message. But if he create the script again it works for the user.

Any idea why this happens



7 Replies
Partner - Creator III
Partner - Creator III

Hi Shemeel,

I've experienced the same issue today. When creating the script in QV desktop in local, the relaod runs well. But when I deploy the qvw on the server and run the reload task it fails with the Access Denied message.

We've set full control on sharepoint list to QV service account using AD and Sharepoint server is list on trusted sites (just fyi all is accessed through VPN but i am pretty sure this it is not the source of our problem.

Do I well understand if I will rebuilt the script in a desktop installed in the server, logged with QVService it will run correctly?

Did you succeed to solve this issue from your side?



Contributor III
Contributor III

Hi guys. We have installed Publisher Qvw11 SR2 in 64 bit edition.

I'm reading data from an excel file in sharepoint. Using information from other discussions, I connected and loaded the data in qvd files through qvw files without problem. But when I tried to load them in QMC reload calendar, them failed with error messages of "Access is denied" .

I verified the IE security configuration in Internet section and modified the trusted sites, but the problem did not was corrected. My UserID and QMC UserID have propietary profiles, then I supposed that they have complete security access.

Can somebody help me with this issue?


I had a similar issue. Created a document on my computer that referenced a file via URL from sharepoint. Worked fine on my computer, but would not load on QV server via scheduled load.

I logged on to the QV server as the login used to run the QV services. I opened up IE and added the sharepoint site as a local intranet site in the "Sites" setting under IE-->Tools-->Security-->Local Intranet-->Sites.

There may be an easier way to resolve this, but the above worked for me.

Contributor III
Contributor III

It works fine in reload through QMC.

Thanks a lot for your answer


Still not working on my end. Running the script in the Qlikview server using the account that runs QMC works fine when using Qlikview Desktop. Fails when run using QMC.

1/2/2014 2:36:56 PM:       Error: The download failed

When using MS Access a bridge, works when using Qlikview Desktop but not using QMC.

1/2/2014 2:10:44 PM:       Error: SQL##f - SqlState: S0002, ErrorCode: 4294965991, ErrorMsg: [Microsoft][ODBC Microsoft Access Driver] The Microsoft Access database engine could not find the object 'Accounts'. Make sure the object exists and that you spell its name and the path name correctly. If 'Accounts' is not a local object, check your network connection or contact the server administrator.

Any thoughts?


I had not seen your question...sorry about that.

We did NOT use MS Access as a bridge. After reading this post we decided to go with the RPC approach.


This also happened to me.

And the code was analyzed as follows:



SQL from table in Connect1


SQL from table in Connect2



SQL from table in Connect1




I decided entering again Connect1 before the table_x