Qlik Community

QlikView Administration

Discussion Board for collaboration on QlikView Management.

Showing results for 
Search instead for 
Did you mean: 
Not applicable

Plugin installed, but does not show up in IE

We're experiencing a General Problem with the QV ActiveX Plugin.

Although installed in the same way on all our machines, some browsers refuse to handle qvw documents. I checked the extensions list of one of these machines, and QV doesn't show up.

Is there something we might have done wrong? It works for most machines, so it can hardly be a misconfiguration, can it?

Thanks a lot in advance / Best wishes


Labels (1)
1 Solution

Accepted Solutions
Not applicable


Looks like I got it sorted out!

It was a new installation of Windows Server 2008, so after I installed a number of Windows Updates, especially the updates concerned with Security and ActiveX, I restarted the machine and tried again.

I received a warning message that said that the site was not trusted. I needed to add two sites to the trusted sites list. After that, it opened perfectly!

Hope this helps someone else...


View solution in original post

34 Replies
Not applicable

We're having the same problem. The machine in question is a Windows Server 2008 x86 Standard with Internet Explorer 8. It's running Terminal Services and Citrix Xenapp 5. Our Qlikview server is listed as a trusted site and Protected mode is turned off. The plugin is version 8.50.6299.5.

I've tried uninstalling it and reinstalling it via remote desktop, citrix published desktop and local console. I've tried as a domain admin and as the machines local admin. I've tried installing it for all users and for the current user only. I've tried running the installer both in execute and install mode.

All with the same result:

No errors, the plugin just doesn't show up in Internet Explorer.

At this point, any suggestions would be greatly appreciated.



Just an idea: is IE8 already officially supported by QlikView (8.5)?


can you make out a different behavior depending on browser version?


Not applicable


since our it guideline forbids browsers other than IE6, we can't test other browsers on the machine in question.
But as a result of the same guideline, we all use the same browser - QV working for some but failing to work for a
handful of others.

I just contacted support, and here's what they propose:
Register QlikOcx.ocx (regsvr32 "C:\Program Files\QlikView\QlikOcx\qlikocx.ocx")
Register qvp.dll (regsvr32 "C:\Program Files\QlikView\QvProtocol\qvp.dll")
Add the Serveradresse to "Trusted Sites"

I'll write a short note after I tried this.



Not applicable

I haven't been able to find out one way or another. The consultant that is here helping us upgrade our server installation seems to think so.

I've tried a few more combinations. Internet Explorer 8 on XP runs fine. As does Internet Explorer 7 on Server 2008. it seems the combination of Internet Explorer 8 and server 2008 is the problem in our case.

I've also tried now to register the components by hand as per Sebi's post without any sucess.


Not applicable

I haven't had any success with that either. But as I said, in our case all OS/Browser constellations are equal.

Our windows admins have completely re-setup one of the systems and it works after that - which is not a pleasant way of getting a browser plugin to work...

Not applicable

When we were using the plugin we had issues with the plugin not running with ie 7 on windows vista.

Not applicable

Any updates on this? I am having the same problem - my IE plugin is not working.

I have uninstalled and reinstalled the plugin, uninstalled & reinstalled IE 8, restarted Windows, registered qlikocx.ocx & qvp.dll...

Not applicable


Bad news I'm afraid. After looking at it together with a support tech from Qliktech I was informed that the plugin is currently not supported together with IE 8, and I was advised to go back to running it in IE 7 until some time next year, when he estimated they would have support for IE8 in place.

I'm fortunate enough that I can publish IE 7 as a streamed application in my Citrix-farm and work around it that way though.

Please let me know if you find a solution to the problem though.



Not applicable


Thanks for the reply - that is good information to know. If this is truly the case I am somewhat disappointed by the lack of transparency on this issue by the company. QlikTech: this is HUGE. Where is the communication?