Qlik Community

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Customer & Partners, DEC. 9, 11 AM ET: Qlik Product & Strategy Roadmap Session: Data Analytics REGISTER NOW
cancel
Showing results for 
Search instead for 
Did you mean: 
lornafnb
Creator
Creator

Copy command not working

hi guys

PFA

I store my qvd location in a variable called  vQvDataWrite.

My qvd file fullname is a combination of vQvDataWrite and 'Africa_ ' and '$(vMaxRecPeriod).qvd'.

My code works correctly that it finds the qvd, but the copy statement fails.

 

I am sure its a combination of the variables and the constants not working.

 

Please can anyone assist?

Thanks.

Labels (1)
1 Solution

Accepted Solutions
kaushiknsolanki

Hi, You have extra '\' in execute command which is probably causing this issue. Try this.

execute cmd.exe /c copy "$(vQvDataWrite)Africa_$(vMaxRecPeriod).qvd" "$(vQvDataWrite)Backup";

 

I have removed "\" which was there before the Backup keyword.

 

 

Regards,
Kaushik
If reply is satisfactory, please "Like" the post.
If reply is solution, please mark as "Correct".

View solution in original post

2 Replies
kaushiknsolanki

Hi, You have extra '\' in execute command which is probably causing this issue. Try this.

execute cmd.exe /c copy "$(vQvDataWrite)Africa_$(vMaxRecPeriod).qvd" "$(vQvDataWrite)Backup";

 

I have removed "\" which was there before the Backup keyword.

 

 

Regards,
Kaushik
If reply is satisfactory, please "Like" the post.
If reply is solution, please mark as "Correct".

View solution in original post

lornafnb
Creator
Creator
Author

thank you