Skip to main content
Announcements
See what Drew Clarke has to say about the Qlik Talend Cloud launch! READ THE BLOG
cancel
Showing results for 
Search instead for 
Did you mean: 
svsudhakar
Creator
Creator

Issue while exporting the huge data to Excel.

Hi ,

when no of rows are huge(Probably >65k), the send to excel exports it to a csv instead of an excel.

In csv format: the number of decimal places gets restricted whereas in excel the entire decimal no's are intact.

Ex:

Original number : 150.23456

Ex: In Excel value coming as 150.23456

In CSV : value is coming based on application number restriction. (Ex : 150.23)

because of this Total values are not matching.

Please help on this issue ASAP.

Regards,

Sudhakar

4 Replies
Gysbert_Wassenaar

There's a setting that you can change to increase the limit before the data is exporting in csv format: RowLimitForCsvInsteadOfXls

On the server you can change the limit in the QVS settings.ini file

[Settings 7]

RowLimitForCsvInsteadOfXls=65500

In Qlikview Desktop you can change this with an 'easter egg' setting. In the Help menu select About Qlikview. Then right click on the Qlikview icon in the lower left corner. Find the entry RowLimitForCsvInsteadOfXls. You can then increase the value from 65500 to a higher number. Note, this may cause a performance penalty on your server.


talk is cheap, supply exceeds demand
svsudhakar
Creator
Creator
Author

Thanks Gysbert...its working fine..

Not applicable

Hi Gysbert

I tried doing this and it does send the data to Excel. But since it is exporting in the (old) .xls format one sheet can contain only 65000 and it creates multiple sheets.

How can we direct it to export to Office 2007 or 2010 (I have 2007 on one PC and 2010 on my laptop)

Thanks.

Gysbert_Wassenaar

That's only possible with a macro: Re: QV to excel 2010? But such a macro won't work when you use the ajax client with documents deployed on the access point.


talk is cheap, supply exceeds demand