Qlik Community

Ask a Question

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Live chat with experts, bring your API Integration questions. June 15th, 10 AM ET. REGISTER TODAY
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Simple .qvw file access via access point

Hi,

I have a .qvw document which i have placed inside QlikTech/Documents folder. It is just a simple .qvw file(and no source). I want to grant access to few users on access point to view this document.

As a named user, I can see and access this document via access point. But, when I assign a document CAL to this document to the user, he/she is not able to access the same. It gives error message: "Failed to open document, you don't have access to this document".

Has anybody came across this kind of issue ?

How can a user access this document via access point when assigned a document CAL ? Let me know if I'm missing something here.

Any help/suggestion on this regard is much appreciated.

Thanks..!!

Regards,

Roushan

18 Replies
Not applicable
Author

I have verified, and it is unchecked. Also, I would like to highlight that, if you see in my above picture attachment, there are other .qvw files, for which the user is able to access via accesspoint(its qlikview webserver) when given a document CAL. Also, other qvw files have some source which are put inside the source document.

But the file which i have circled in red i.e. BIIT_v5.qvw has no source. Is that something which is restricting the access ? Please help.

fabrice_lawson
Employee
Employee

is it possible that you can scramble the data and send the qvw file?

Not applicable
Author

My worry is that, do I need to assign named user cal for this document ? Because with named user cal, i think its is accessible, but not with document cal. I don't think I would be able to send .qvw file. Basically, it is just a very simple file with some business data which needs to be published on web server and to be accessed via the access point.

The problem is that, i cant provide named user call to all because we have very limited #of named cals.

martinpohl
Partner
Partner

so my question about webserver or iis.

Wihtin a document cal it is not possible to get access to a document without authentication.

Is the user authenticated at the accesspoint?

fabrice_lawson
Employee
Employee

with a doc cal, you give the opportunity to users to open the document using a cal

anonymous will not work as this is more for session cal.

with that said with doc cal, webserver or iis with ntfs or dms the users need to get authenticated on the accesspoint.

however I assume you have this setup already as this is working for other documents on the accesspoint.

what is the result if you tested with the attached application?

thank you

Not applicable
Author

I did as below

1. Placed CtrlQ-TestData.qvw inside QlikTech\Documents folder. After this, I was able to see this in access point(I have a named user CAL, and copied the link).

2. Assigned one document CAL in QMC for this qvw to a user(my colleague).

3. I sent the link to that user to access the document on web.

But, It still throws the same error: "Failed to open document, you don't have access to this document".

Do I need any correction in above steps, or is fine ?

fabrice_lawson
Employee
Employee

you cannot do that!

you cannot copy the link of your authentication to him.

what you need to do is to send him the link of the accesspoint, and for him to pick the document and open it, as a first step at least.

can you confirm if you are on NTFS or DMS mode?

at this stage do you know if he has access to the accesspoint?

Not applicable
Author

I think, I'm able to solve this 🙂

the problem was that 'All Authenticated User' was not assigned to the document, as it was copied directly inside the document. If we publish it via QMC there is an option to assign 'All Authenticated User' to the document. I then, assigned the permission manually on the server, and is accessible now.

Thanks a lot guys for all your help.

Much appreciated.

View solution in original post

Not applicable
Author

nice