Skip to main content

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
CUSTOMERS ONLY: Now accepting customer applications for the 2023 Luminary Program: SUBMIT NOW
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Straight table issue

Dear All,

I am searching on following problem.

I've created a straight table and with certain selections I generate the output below:

I don't want to see dimensions where all data is 0 or '-'. I only want to see the columns with actual data (6,5 and 4)

All options 'Suppress When Value is Null' are already flagged in the object.

Any other ideas/proposals?

Kind regards,

CM

1 Solution

Accepted Solutions
sunny_talwar

The culprit here was division 1 which was stamping ='' a space for all your dimension values. Check this now

Capture.PNG

View solution in original post

10 Replies
sunny_talwar

Is this a straight table or pivot table? In essence, 4,5,6,7,8,9 are dimensions or expressions?

Not applicable
Author

Hi Sunny,

These are Dimensions, the Chart Type is a Straight Table.

Best regards,

Anil_Babu_Samineni

Will you able to provide Expression? It may help if you provide sample data

Before develop something, think If placed (The Right information | To the right people | At the Right time | In the Right place | With the Right context)
sunny_talwar

Have you checked 'Suppress Zero Values' on the presentation tab?

Not applicable
Author

Yes I did. Any other options that might have influence?

vinieme12
Champion III
Champion III

Will need a sample to see what's going on.

Preparing examples for Upload - Reduction and Data Scrambling

Vineeth Pujari
If a post helps to resolve your issue, please accept it as a Solution.
Not applicable
Author

Here you go

sunny_talwar

The culprit here was division 1 which was stamping ='' a space for all your dimension values. Check this now

Capture.PNG

Not applicable
Author

Hi Sunny,

Thanks for the help. I'm just struggling now with a last issue.

How do you do it if you want you division to be the first record? In this case your solution seems not to work...

Best regards,

Mathias