Qlik Community

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Join “Do More With Qlik” with Mike Tarallo to get a first-hand look at the New Authoring Experience, June 29th: REGISTER HERE
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

need help with (grid-?) chart

Hi there,

I was asked to create a (grid-?) chart with the following dimensions:

x-axis:

- price range [0-50, 51-100, 101-150, 151-200 for example]

y-axis:

- some kind of ratio (0-100%)

All that in the relation to a total number.

Here is an example:

The data table is roughly:

- id (int)

- range (text)

- accepted (bool)

If I have the two dimensions "range" and the calculated dimension "sum(accepted)/count(id)" I always get an "error in calculated dimension".

Does anyone know how to solve that problem?

Any help is appreciated.

1 Solution

Accepted Solutions
tresesco
MVP
MVP

In the calculated dimension, you have to use Aggr() alongwith any aggregation function. Hence, try like:

Aggr(sum(accepted), Dim1) /Aggr(count(id), Dim1)

View solution in original post

5 Replies
tresesco
MVP
MVP

In the calculated dimension, you have to use Aggr() alongwith any aggregation function. Hence, try like:

Aggr(sum(accepted), Dim1) /Aggr(count(id), Dim1)

avinashelite

sum(accepted)/count(id) this the error for the "Error in calculated dimension" we cannot use this kind of calculation in dimension unless it will calculate using AGGR fundtion.

Try like aggr(sum(accepted)/count(id),calculation_on_dimension_required)



if you share the exact requirement we can help you 

Not applicable
Author

Hi the both of you!

Your help really pointed me to the result I was looking for.

Thanks a lot for your help!!!!

avinashelite

mark the helpful and correct answers

Not applicable
Author

Hi again,

I would like to add a question to the upper part.

The scale for the y-axis is in percent but it is always autoscaling (e.g. max val is 60% so it ends with 60%).

Within the properties --> axes setting I can not edit the "static max" value.

Does anyone know how I can change it so that the y-axis is always showing 100%?

Thanks and regards