Qlik Community

Security & Governance

Discussion board where members can learn more about Qlik Sense deployments which are governed and self-service.

cancel
Showing results for 
Search instead for 
Did you mean: 
soka41
Contributor III
Contributor III

"An error occurred , Not connected" message on a app every two minutes Qlik sense Nov. 2018 on a multinode site

Im on Qlik Sense Nov. 2018 on a multi node site.(Qlik Sense Proxy Service (QPS) is allow in the Master and rim node)

When i'm in  app, every two minutes i have this messeage "An error occurred , Not connected" in firefox, chrome and edge, but in internet explorer a have no problem, it work correctly.

When i'm in a hub, every two minutes i have other messe "An error occurred, Connection los..... " in firefox, chrome and edge, but in internet explorer a have no problem, it work correctly.

I have read some articles on a community, i found two solutions  :

1. Update the WebSocketPingInterval to 300

2. Make 300 seconds in QMC keep alive under proxy sections

I use all of this sulutions but it not work (i applied solutions only in a Master node).

I joined the Config proxy file for Central and RIM Node and QMC Virtual proxy Config.

Labels (1)
1 Solution

Accepted Solutions
soka41
Contributor III
Contributor III
Author

Hello @Bastien_Laugiero 

I solved the problem.
It was the browser-level proxy setting that was causing the problem.
I checked the automatic detection option of the network proxy settings and it works fine.

thank to you.proxy.PNG

 

View solution in original post

6 Replies
Bastien_Laugiero

Hi,

The WebSocketPingInterval needs to be lower than the frequency of the timeouts. Based on your description you have configured Qlik Sense to send a keepalive ping every 5 minutes (300 Seconds) while the disconnection occurs every 2 minutes. 

Can you try to set it to 60 seconds instead? 

 

Bastien Laugiero
If a post helps to resolve your issue, please mark the appropriate replies as CORRECT.
soka41
Contributor III
Contributor III
Author

Hello,

Where i am supposed to change the WebSocketPingInterval to 60 seconds ?

Thank you.

Bastien_Laugiero

Hello, 

Here is the article https://community.qlik.com/t5/Knowledge-Base/Enabling-TCP-Keep-Alive-Functionality-In-Qlik-Sense/ta-...

 

Bastien Laugiero
If a post helps to resolve your issue, please mark the appropriate replies as CORRECT.
soka41
Contributor III
Contributor III
Author

I make all recommandations, but i have the same message error every two minutes.

With WebSocketPingInterval  to 60 in the proxy.exe.config.

My log AuditActivityProxy attached with the error "Not available Proxy AppAccess" and "Close connection 0 Backend web socket connection Closed"

Bastien_Laugiero

Thanks for the feedback. 

Could you remote access the Qlik Sense server and connect to the hub using https://localhost/hub

If you cannot see the issue there, then it means that there is most likely a network equipment in your environment cutting off the connection after two minutes. 

 

Bastien Laugiero
If a post helps to resolve your issue, please mark the appropriate replies as CORRECT.
soka41
Contributor III
Contributor III
Author

Hello @Bastien_Laugiero 

I solved the problem.
It was the browser-level proxy setting that was causing the problem.
I checked the automatic detection option of the network proxy settings and it works fine.

thank to you.proxy.PNG