3 Replies Latest reply: May 20, 2014 4:23 AM by Matthew Howlett RSS

    Execute external program - Java command line not working in publisher

    Matthew Howlett

      Hi,

       

      I have a QlikView document which executes an external program (Java), then reads in the output file that it created, does some transformation and stores the results to a QVD. This works fine in development and I can log onto the server as the service account and it works runs fine when I run it as the service account on the server. However, when I try and run it through the QEMC as a task it does not work correctly. It does not fail but clearly does not execute the Java command line because the timestamp on the output file from the Java call does not change, but the stored QVD timestamp does, it is like it just ignores this step completely

       

      I have managed to schedule a number of other QlikView documents which execute standard external command line executableslike "copy" without any issues. I have the "Can Execute External Programs" box checked in the application and I believe the publisher is setup correctly.

       

      I've also tried setting up bat files and executing the bat file in QlikView instead of Java directly and it doesn't work or make any difference.

       

      Anybody been able to setup/schedule a QlikView document to call Java or some other custom executable from Publisher?

       

      Thanks,

      Matt