2 Replies Latest reply: Apr 21, 2017 10:15 AM by Catalin Plitea RSS

    Get data from Sharepoint list into Qlik Sense

    Catalin Plitea

      Hi and thanks in advance for taking the time to read.

       

      Does anyone know a good method to get data from a Sharepoint List into Qlik Sense.  I have tried the following, but nothing worked so far:

       

      1.  Create Web file conection and paste the Url of the site as appears in the browser:

                https://xxxxxxxxx.sharepoint.com/Catalin_Test2/IssueT/SitePages/Home.aspx 

          The connection is made, but when I try to get data, instead of a table, qlik is trying to fetch this:

      "We can't sign you in.Your browser is currently set to block cookies. You need to allow cookies to use this service ......" 

      All my browsers accept cookies... What specific browser is Qlik talking about ?

        This method works if I try to get the data into Qlik View with no problems.


      2. I tried using this URL : http://xxxxxxxx.sharepoint.com/Catalin_Test2/IssueT/_vti_bin/owssvr.dll?Cmd=Display&XMLDATA=0&RowLimit=0&List=afe7b568%2D8bf9%2D475d%2Dbade%2Ddb9e255d1665

      which I found on qlik view forums, but I get nothing when I choose XML file in the process...


      3. I used the Sharepoint "Export to Excel" (which for me only worked in Internet explorer) ... This exports a owssvr.iqy file, which I can open with excel and then save as an xlsx file ...and get data into Qlik Sense from this file... This works, but the problem is that I can only make this xlsx file refresh data (from Sharepoint) on reopening (the xlsx file)...

      So if I want my qlik sense application get updated data, I have to manually reopen the XLSX file... which is a problem, because in the near future I want to put the app on Qlik Server and make automate refresh of data... Even if I leave the xlsx file opened all the time, the "Refresh every n minutes" option is grayed out and not usable.


      Sorry for the long post... Any ideeas ?

      Tomorrow I will try to use Open in Access instead of Excel, and see if I get anything.

      Thanks.