2 Replies Latest reply: Jul 19, 2017 7:31 AM by Mihai Hutanu RSS

    Scheduler - Slave node not running any task

    Mihai Hutanu

      Hello,

       

      I have a 4 nodes Qlik Sense 3.2.2 site (shared persistence) as follows:

       

      • Central Node - Proxy + Scheduler
      • RIM1 - Proxy + Scheduler
      • RIM2 - Engine + Printing
      • RIM3 - Engine + Printing


      As you can see 2 of the nodes will be used for reloads (scheduler service). The configuration is as follows:


      • Central Node - Master and Slave
      • RIM1 - Slave


      I am having the following problem: all the tasks are executed by the Central Node. I tried starting about 10 tasks at one time and all were started on Central node and none on the Slave node. Of course, 4 tasks started right away, the rest were queued.


      I activated Debug log, and found the following entries in the log file:


      • Slave-node <RIM1> is not alive and cannot run task <task>
      • Slave-node <RIM1> is disabled and cannot run task <task>

       

      Ports open through firewall as follows:

       

      Central

      Outbound -> 5151

      Inbound   -> 5050


      RIM1

      Outbound -> 5050

      Inbound   -> 5151

       

      I have tried opening both ports in both directions on both servers, made no difference.

       

      I also tried to change the Central Scheduler to Master only, but then the tasks will fail saying "no slave nodes found".

       

      Any advise would be much appreciated!

       

      Kind regards,

      Mihai