13 Replies Latest reply: Jan 12, 2018 10:39 AM by Téhodore Bidon RSS

    Qliksense Installation Error (1603)

    Amrinder Sidhu

      Hello All,

       

      I am trying to install qliksense desktop June 2017 version(Personal edition) but facing error. Folders, Files everything gets created then it is rollbacked and error is displayed saying check the log file.I have done/checked all below:

       

      • Installed .net framework 4.5.2
      • Cleared Temp Data and Package Cache
      • Installed Microsoft visual C++ Packages
      • Made changes in registery.
      • Checked Permissions and everything

       

      Apart from this if anybody has a solution kindly help me out. I am attaching Log file and snapshot for reference.

       

      Error.png

        • Re: Qliksense Installation Error (1603)
          Kaushik Solanki

          Check the solution given on this link.

           

          https://community.qlik.com/thread/168527

           

          Regards,

          Kaushik Solanki

            • Re: Qliksense Installation Error (1603)
              Amrinder Sidhu

              Hi Kaushik,

              Thanks for reply.

              But Microsoft Visual C++ =redistributable Package(2008,2010,2012,2013,2015) are already installed on my system.

                • Re: Qliksense Installation Error (1603)
                  Kaushik Solanki

                  Check if they are for 32 bit or 64 bit.

                   

                  Regards,

                  Kaushik Solanki

                      • Re: Qliksense Installation Error (1603)
                        Anand Chouhan

                        Also check will this machine contains proper security or windows licence and they are updated also.

                          • Re: Qliksense Installation Error (1603)
                            László Gyimesi

                            Hi,

                             

                            I have the same issue: fresh Qliksense install (not upgrade) on Windows 10 stops with error message (see attached). If I look at the last page of the 80MB install log (see below), I see 1603 error.

                             

                            C++ components installed properly (see attached). I tried after several restarts, no success.

                             

                            What else should I try?

                             

                            MSI (s) (E0:A4) [13:26:35:215]: Note: 1: 1708

                            MSI (s) (E0:A4) [13:26:35:215]: Note: 1: 2205 2:  3: Error

                            MSI (s) (E0:A4) [13:26:35:215]: Note: 1: 2228 2:  3: Error 4: SELECT `Message` FROM `Error` WHERE `Error` = 1708

                            MSI (s) (E0:A4) [13:26:35:215]: Note: 1: 2205 2:  3: Error

                            MSI (s) (E0:A4) [13:26:35:215]: Note: 1: 2228 2:  3: Error 4: SELECT `Message` FROM `Error` WHERE `Error` = 1709

                            MSI (s) (E0:A4) [13:26:35:215]: Product: Qlik Sense Desktop -- Installation failed.

                             

                             

                            MSI (s) (E0:A4) [13:26:35:216]: Windows Installer installed the product. Product Name: Qlik Sense Desktop. Product Version: 11.14.3. Product Language: 1033. Manufacturer: QlikTech International AB. Installation success or error status: 1603.

                             

                             

                            MSI (s) (E0:A4) [13:26:35:266]: Deferring clean up of packages/files, if any exist

                            MSI (s) (E0:A4) [13:26:35:268]: MainEngineThread is returning 1603

                            MSI (s) (E0:08) [13:26:35:273]: RESTART MANAGER: Session closed.

                            MSI (s) (E0:08) [13:26:35:273]: No System Restore sequence number for this installation.

                            === Logging stopped: 2017. 10. 19.  13:26:35 ===

                            MSI (s) (E0:08) [13:26:35:280]: User policy value 'DisableRollback' is 0

                            MSI (s) (E0:08) [13:26:35:280]: Machine policy value 'DisableRollback' is 0

                            MSI (s) (E0:08) [13:26:35:280]: Incrementing counter to disable shutdown. Counter after increment: 0

                            MSI (s) (E0:08) [13:26:35:280]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2

                            MSI (s) (E0:08) [13:26:35:280]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2

                            MSI (s) (E0:08) [13:26:35:281]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied.  Counter after decrement: -1

                            MSI (s) (E0:08) [13:26:35:282]: Destroying RemoteAPI object.

                            MSI (s) (E0:34) [13:26:35:282]: Custom Action Manager thread ending.

                            MSI (c) (20:1C) [13:26:35:284]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied.  Counter after decrement: -1

                            MSI (c) (20:1C) [13:26:35:284]: MainEngineThread is returning 1603

                            === Verbose logging stopped: 2017. 10. 19.  13:26:35 ===""

                            • Re: Qliksense Installation Error (1603)
                              Amrinder Sidhu

                              Thank You Anand!

                               

                              Actually due to antivirus restrictions installation was getting rolled back.

                    • Re: Qliksense Installation Error (1603)
                      Téhodore Bidon

                      Hi all,

                       

                      About every things here append to me too.

                      So I update visual C++, create a new admin to install the product, etc...

                       

                      No luck for me.

                       

                      So I decide to extract the MSI form the installer (via 7zip) and try to install them one by one.

                       

                      Only qliksense desktop doesn't install and It seems to stop only at the end.

                      What is causing the issue seems to be here in msi install logs :

                       

                      --------------------

                      WriteRegistryValues: Key: \Software\Classes\qliksense\shell\open\command, Name: , Value: "C:\Users\qlik\AppData\Local\Programs\Qlik\Sense\QlikSenseBrowser\QlikSenseBrowser.exe" "--magiclink=%1"

                      MSI (s) (88:C4) [14:04:54:075]: Executing op: ActionStart(Name=CA_ConvertToUTF8,,)

                      Action 14:04:54: CA_ConvertToUTF8.

                      MSI (s) (88:C4) [14:04:54:076]: Executing op: CustomActionSchedule(Action=CA_ConvertToUTF8,ActionType=1025,Source=BinaryData,Target=CAQuietExec,CustomActionData="powershell" -NoLogo -NonInteractive -InputFormat None –ExecutionPolicy Unrestricted -Command "if (Test-Path -path 'C:\Users\qlik\AppData\Local\Programs\Qlik\Sense\Engine\Settings.ini') {{ (Get-Content 'C:\Users\qlik\AppData\Local\Programs\Qlik\Sense\Engine\Settings.ini') | Set-Content -Encoding UTF8 -Force 'C:\Users\qlik\AppData\Local\Programs\Qlik\Sense\Engine\Settings.ini'" }})

                      MSI (s) (88:D8) [14:04:54:085]: Invoking remote custom action. DLL: C:\WINDOWS\Installer\MSID96E.tmp, Entrypoint: CAQuietExec

                      MSI (s) (88:1C) [14:04:54:085]: Generating random cookie.

                      MSI (s) (88:1C) [14:04:54:105]: Created Custom Action Server with PID 19044 (0x4A64).

                      MSI (s) (88:C4) [14:04:54:145]: Running as a service.

                      MSI (s) (88:C4) [14:04:54:147]: Hello, I'm your 32bit Impersonated custom action server.

                      CAQuietExec:  Entering CAQuietExec in C:\WINDOWS\Installer\MSID96E.tmp, version 3.10.2103.0

                      CAQuietExec:  "powershell" -NoLogo -NonInteractive -InputFormat None

                      CAQuietExec:  Error 0x80070002: Command failed to execute.

                      CAQuietExec:  Error 0x80070002: QuietExec Failed

                      CAQuietExec:  Error 0x80070002: Failed in ExecCommon method

                      CustomAction CA_ConvertToUTF8 returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)

                      Action ended 14:04:54: InstallFinalize. Return value 3.

                      MSI (s) (88:C4) [14:04:54:226]: Note: 1: 2265 2:  3: -2147287035

                      MSI (s) (88:C4) [14:04:54:227]: User policy value 'DisableRollback' is 0

                      MSI (s) (88:C4) [14:04:54:227]: Machine policy value 'DisableRollback' is 0

                      MSI (s) (88:C4) [14:04:54:346]: Executing op: Header(Signature=1397708873,Version=500,Timestamp=1268084832,LangId=1033,Platform=589824,ScriptType=2,ScriptMajorVersion=21,ScriptMinorVersion=4,ScriptAttributes=0)

                      MSI (s) (88:C4) [14:04:54:346]: Executing op: DialogInfo(Type=0,Argument=1033)

                      MSI (s) (88:C4) [14:04:54:347]: Executing op: DialogInfo(Type=1,Argument=Qlik Sense Desktop)

                      MSI (s) (88:C4) [14:04:54:347]: Executing op: RollbackInfo(,RollbackAction=Rollback,RollbackDescription=Rolling back action:,RollbackTemplate=[1],CleanupAction=RollbackCleanup,CleanupDescription=Removing backup files,CleanupTemplate=File: [1])



                      ------------------

                      2 things in bold :

                           - Somethings with 32bits and UTF8 just before rollback (I'm on 64bits updated windows 10)

                           - User policy for rollback

                       

                      As I can disable rollback, I tryed.

                      You can do it via registry

                       

                      Here is the content of the dot reg file that can do that :

                       

                      [HKEY_CURRENT_USER\SOFTWARE\Policies\Microsoft\Windows]

                      "DisableRollback"=dword:00000001

                       

                      obviously, the installation do not end correcly.

                      BUT ! qliksense desktop is install and seems to work. (for what I can do with it for now)

                       

                      Don't forget to install the others MSI or you will miss connectors at least.

                       

                      Hope that can help somebody.