1 Reply Latest reply: Nov 10, 2017 1:24 PM by igor gois RSS

    install ssl certificate from go daddy in qlik sense

    igor gois

      im facing issues to install ssl certificates from godaddy

       

      my steps:

       

      1- generate the .csr using openssl as said in the pdf here: Generating Certificate Signing Requests for Trusted Certificates

       

      2- import .csr to godaddy to receive the .crt files (there are two: 1cc55b4bfa47af38.crt and gd_bundle-g2-g1.crt). Acctually, godaddy give options to choose what server i will use the certificates (apache, iss, tomcat, macos, exchange, others) I chose 'others', but im not certain about that

       

      3- generate the .pfx file using openssl as said here: Create a .pfx/.p12 certificate file using OpenSSL - SSL.com ps: i used the two crt files. The 1cc55b4bfa47af38.crt as -in parameter and gd_bundle-g2-g1.crt as the -certfile optional parameter


      4- imported the .pfx file as said here: https://support.aginic.com/support/solutions/articles/14000031148-applying-an-ssl-certificate-to-qlik-sense


      5- At this moment, 4 certificates showed up. I moved the Root certificate to Trusted Root Certificate Authorities\Certificates folder as Jeffrey said here: Installing SSL Certificate for Qlik Sense.


      6- Copied the thumprint into proxies in qmc and restart qmc


      7-Tried to access the sevrer using https: and get the error:

      NET::ERR_CERT_COMMON_NAME_INVALID

       

      Could you help me?

        • Re: install ssl certificate from go daddy in qlik sense
          igor gois

          just got the ssl certificate working. Here some highlights:

           

          - the certificate was generated in go daddy to domain.com.br. And I will use the domain: bi.domain.com.br. Once we regenerated the certificate to bi.domain.com.br everything worked fine

           

          - Once we have the right certificate, I downloaded from go daddy using the IIS server option and got 2 files: one .crt and another one .p7b

           

          - Generated the .pfx certificate with open ssl using the .key (used to generate the .csr) and the .crt from go daddy


          - Installed the .pfx certificate and input the thumprint on qmc


          Now everything is working!!!