Skip to main content
Announcements
Qlik Introduces a New Era of Visualization! READ ALL ABOUT IT
cancel
Showing results for 
Search instead for 
Did you mean: 
shruthibk
Creator
Creator

Help with REST connector set up

Hi All,

I am trying to connect to NEO4j data base using qliksense through REST API connection but i am unable to understand how to get the api end point and pass the cyper query . Could anybody please guide me or share the poc if you have.

Thanks in advance

Labels (1)
1 Solution

Accepted Solutions
Jay_Brown
Support
Support

It appears that the Neo4j REST API has been deprecated.  
https://neo4j.com/docs/rest-docs/current/ 

You may want to reach out to the Neo4j team for more information for that particular connection method.

Otherwise I suggest you check out the ODBC documentation such as that from Simba:
https://insightsoftware.com/drivers/neo4j-odbc-jdbc/ 
And use the ODBC connection method within Qlik:
https://help.qlik.com/en-US/sense/May2023/Subsystems/Hub/Content/Sense_Hub/DataSource/ODBC.htm?_ga=2... 

To help users find verified answers, please don't forget to mark a correct resolution or answer to your problem or question as correct.

View solution in original post

2 Replies
Jay_Brown
Support
Support

It appears that the Neo4j REST API has been deprecated.  
https://neo4j.com/docs/rest-docs/current/ 

You may want to reach out to the Neo4j team for more information for that particular connection method.

Otherwise I suggest you check out the ODBC documentation such as that from Simba:
https://insightsoftware.com/drivers/neo4j-odbc-jdbc/ 
And use the ODBC connection method within Qlik:
https://help.qlik.com/en-US/sense/May2023/Subsystems/Hub/Content/Sense_Hub/DataSource/ODBC.htm?_ga=2... 

To help users find verified answers, please don't forget to mark a correct resolution or answer to your problem or question as correct.
Henriette
Contributor
Contributor

Hi Jay

Similar situ - I have connected successfully through Postman so I have confirmed that the BLS API
https://api.bls.gov/publicAPI/v2/timeseries/data/
is working.  I actually get a Successful COnnection from Qlik (see Screenshot) But 4 the life of me I cannot understand why it will not allow me to select the data - Here is the error message 

Henriette_1-1697475183275.png

 


Here is the payload body:
{"seriesid":["JTU620000000000000HIL","JTU620000000000000LDL", "JTU620000000000000QUL", "JTU620000000000000TSL"[,
"startyear":"2013", "endyear":"2023", "catalog":false,
"calculations":true, "annualaverage":true, "aspects":true,
"registrationkey":"xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx" }

Henriette_0-1697475085173.png

ANy help would be soooooooo appreciated !