Skip to main content
Announcements
Qlik Connect 2024! Seize endless possibilities! LEARN MORE
cancel
Showing results for 
Search instead for 
Did you mean: 
TeunJacobs
Contributor
Contributor

Qlik Sense crashes when string in SQL server field is too long

Hello fellow Qlik'ers, 

Within our company we're moving to the latest version of Qlik Sense November 2022 Patch 3.
The old environment is still running on Qlik Sense April 2019. 

Within the new version I've set up a connection to our Microsoft SQL Server (on-premise) like I have in the old environment. In the new environment when creating the connection you have one setting called [Max string length]. The maximum value that you can enter here = [16384]. In the old environment there is no setting like this. 

When I'm trying to load a table which has a very long string in a field (in my case I'm loading a table with BASE64 images) the app crashes. Where the documentation is saying that if a string is longer than the set value, it will be truncated, and the exceeding characters will not be loaded. I've the feeling that this is not true, but that it crashes if the string is too long. 

We are getting errors like: 
[Error row status 5 at 37] 
[
Connector error: Failed to fetch remaining data!]

]

Where the old version of Qlik just loads the field without any issues. Is there a way to solve this issue or work around it? Because it's pretty annoying, you have to guess or debug the data set my making it smaller (in terms of rows and fields) step by step. 

TeunJacobs_0-1675864019688.png

Thanks in advance! 

Labels (2)
1 Solution

Accepted Solutions
RenuLalwani
Employee
Employee

Bulk Reader (the reload optimisation feature, which was added in August 2021)  is now enabled by default in the newer versions of Qlik Sense, hence you don't see that anymore on the UI. [Max string length] only applies when Bulk reader is enabled. 

Bulk reader cannot process fields greater than 16384.

In order to process larger field lengths, you can choose to turn off that feature by adding useBulkReader=false in Advanced properties. 

View solution in original post

1 Reply
RenuLalwani
Employee
Employee

Bulk Reader (the reload optimisation feature, which was added in August 2021)  is now enabled by default in the newer versions of Qlik Sense, hence you don't see that anymore on the UI. [Max string length] only applies when Bulk reader is enabled. 

Bulk reader cannot process fields greater than 16384.

In order to process larger field lengths, you can choose to turn off that feature by adding useBulkReader=false in Advanced properties.