Skip to main content

Connectivity & Data Prep

Discussion board where members can learn more about Qlik Sense Data Connectivity.

Announcements
Welcome to Qlik Community! Check out our new navigation! FIND OUT MORE
cancel
Showing results for 
Search instead for 
Did you mean: 
sebastian_vasqu
Partner - Contributor II
Partner - Contributor II

access denied Qlik FTP / SFTP Connector QlikWebConnectorsNovember2017

Dear, please your help.


I am making a connection via FTP with FTP Download but when making the connection the result of the status that sends me Access to the route C: / Qlik Sense is denied. This same access was made with the version of QlikWebConnectors 2.2 and it worked very well and when using the version of QlikWebConnectors QlikWebConnectorsNovember2017 sent me the error already indicated. what permission should I give it?


The services that run the QlikWebConnectors are running and also have write permissions on the disk so I do not know why it is not working.


This only happens with the new version.


Note: Translation made from google translate.

1 Solution

Accepted Solutions
bam
Employee
Employee

Hi - Could you take a look at the Allow file system access for specified paths section here:

Advanced configuration of Qlik Web Connectors ‒ Qlik Connectors

You now need explicitly white list the paths you would like the connectors to be able to access.

View solution in original post

10 Replies
bam
Employee
Employee

Hi - Could you take a look at the Allow file system access for specified paths section here:

Advanced configuration of Qlik Web Connectors ‒ Qlik Connectors

You now need explicitly white list the paths you would like the connectors to be able to access.

sebastian_vasqu
Partner - Contributor II
Partner - Contributor II
Author

Thanks, add the <FileSystemAccessAllowedPaths> * </ FileSystemAccessAllowedPaths> in the. \ QlikWebConnectors \ deploy.config file and it worked correctly.


Note: Translation made from google translate.

bettina13
Contributor III
Contributor III

Hi Christopher,

I've got the same problem with the SFTPUplaod Connector. I added the FileSystemAccessAllowedPaths-Parameter, but nothing changed. Do you have an idea?

Bettina

stevedark
MVP
MVP

You need to stop and start QWC in order for this setting to be re-read.  Have you restarted the service or closed and opened the app?

bettina13
Contributor III
Contributor III

No, I had not. Now I have and the new message is "Permission denied".

stevedark
MVP
MVP

Where are you seeing this message?

bettina13
Contributor III
Contributor III

In the Data Preview of the FTP/SFTP-Connector

stevedark
MVP
MVP

If you find the URL that is being used on either the QlikView or Qlik Sense tab you can copy and paste this into your browser.  The URL is the part inbetween (i.e. not including) the square brackets at the end of the load script.  The page returned here will give you additional diagnostic information.

I've not used the FTP put connector at this release, but I know some of the other connectors had changes which required that the configuration had to be re-entered, and not always the same.  I had an issue with IMAP where a non SSL port worked prior to the latest release and a different SSL port was required post upgrade.

bettina13
Contributor III
Contributor III

Thanks very much. I deleted the Settings and now it works!