Skip to main content

Deployment & Management

Discussion board where members learn more about Qlik Sense Installation, Deployment and Management.

Announcements
CUSTOMERS ONLY: Now accepting customer applications for the 2023 Luminary Program: SUBMIT NOW
cancel
Showing results for 
Search instead for 
Did you mean: 
gballester
Creator
Creator

Change standar to legacy mode in Sense Server

Hello,

I need to run a February 20202 Qlik Sense Server in Legacy mode.

I followed the instructions in the server manual to change from standard to legacy mode and it doesn't work for me.

In desktop mode the change works ok, not on the server.

I appreciate any help.

Thank you

stdall.png

Labels (3)
8 Replies
Vegar
MVP
MVP

It should work doing as you are showing in your images. Have you tried restarting the qlik engine after you applied the changes?

(Another thought is that you could have active tasks running that is using standard mode connections and thereby blocking the switch) 

Vegar
MVP
MVP

How do you know that it is not working? What are your doing to test and what is the Qlik Sense error response doing so? 

gballester
Creator
Creator
Author

Good morning,

Thanks for your answer.

After changing the mode, I reset the sense services.

To date, we had been working in standard mode and managed to reproduce the directory handling we had in QlikView in QlikSense standard mode using the names of the documents.


We have to automate importing, publishing and assigning custom properties using the external Qlik-cli library which works very well and the idea was to be able to dynamically arm PowerShell commands from a qlikSense app.


But it is very likely that what you mentioned is happening to us, since we have many documents using standard mode connections.

I am going to see if I can get to test in some virtual machine if the problem is in the connections that we have today defined in standard mode.

Thank you very much for your tip.

gballester
Creator
Creator
Author

Hello,

I used an QlikSense installation on a virtual machine.

I removed all apps and data connections.

I passed the server to standard mode removing the tilde in advanced options, as I comment in this case (image).

I added the settings.ini file and its parameters as some indicate.

[Settings 7]
OverrideScriptSecurity = 1
StandardReload = 0

I restart the all services and it keeps giving me this error, which is a typical Qlik] View not QlikSense error.


The following error occurred:
EXECUTE statement requires Script (Allow Database Write and Execute Statements) in User Preferences settings

otavio_marco
Creator II
Creator II

Hi @gballester .

Don't forget de blank line at the end of file. Otherwise doesn't work.

#1 [Settings 7]
#2 OverrideScriptSecurity=1
#3 StandardReload=0
#4 

 

Grupo Telegram Qlik Brasil: https://t.me/joinchat/AeRmnUmcxQ02L00g3x-HtQ
gballester
Creator
Creator
Author

Thanks for your comment Otavio, I just checked and there is no blank line at the end. However it keeps giving the error.

Vegar
MVP
MVP

How are you connecting to the database? Using the build in Qlik ODBC connector package? It is blocking all non SELECT statements as default. You will need to configure it to allow other queries as well.

Take a look at this support page: Connector reply error: Executing non-SELECT queries is disabled. Please contact your system administ... 

gballester
Creator
Creator
Author

Hello,

Thank you all for your contribution.

I was able to solve the issue with the help of José from DataIq.

I was making the ini changes in the Program Files folder, and it was in the same structure in the hidden ProgramData folder.