Skip to main content
Announcements
Marching toward a simplified navigation! READ ON
cancel
Showing results for 
Search instead for 
Did you mean: 
RikEr
Partner - Contributor II
Partner - Contributor II

Novermber upgrade Qlik Enterprise Windows gets stuck at "Installing repository Database"

Hey All,

First off, I am new to this forum. So if I ask a question that was already answered somewhere else, please refer me to that article.

So, the reason I opened this one is that I started an upgrade last week to update our environment to the November 2023 version of Qlik Sense Enterprise on Windows. During the update the installation got stuck during the step "Installing Repository Database". After 8 hours of waiting and concluding the server was idle and not anything I rebooted the server. After which we had to roll back to the backup from the night before

The steps that were taken are that in September/October the postgres database was installed en the repository database service was dissabled. 

The only article I found on this forum was this one. However that did not give any answer as to why and how the problem was resolved. Is there anyone that can help me with this?

Labels (1)
7 Replies
Chetan_MN
Support
Support

Hi @RikEr 

What is the PostgreSql DB version?
What is the version of Qlik Sense you are upgrading from?
Is it possible to share the Installation Logs (https://community.qlik.com/t5/Official-Support-Articles/How-to-troubleshoot-failed-Qlik-Sense-instal...)

RikEr
Partner - Contributor II
Partner - Contributor II
Author

Hey and thanks already @Chetan_MN 

Yes the installation was on de postgres version. The version we were upgrading from is is 14.129.11.00. At least that is what I saw in the Log files.

Attached are all the log files I could find. Hopefully this will shine some light in the darkness.

The installation was started at +/- 10:00 AM and the server was rebooted at +/-17:30 (or 05:30 PM). Between 10:34 and 17:30 I don't see any log-lines.

Chetan_MN
Support
Support

Hi @RikEr 

I could see that there is no log field that would suggest any failure or the installation stuck. 

Did you perform the final steps mentioned in the documentation below to remove PostgreSQL.msi 

https://help.qlik.com/en-US/sense-admin/November2023/Subsystems/DeployAdministerQSE/Content/Sense_De...

A simple reboot would also solve the issue. Make sure to have necessary backup plan before proceeding with anything.

RikEr
Partner - Contributor II
Partner - Contributor II
Author

After the stuck installation I referred to the documentation concerning the upgrade for postgres and saw that de repository database service was still there in the services as well as more than one Postgres*.msi in [...]ProgramData/Package Cache 

Documentation I got from the person that did the installation: https://community.qlik.com/t5/Official-Support-Articles/Upgrading-and-unbundling-the-Qlik-Sense-Repo... 

Now that we have a backup restored the "Qlik Sense Repository Database"-service is gone and only the one for "postgresql-x64-14"-service is available. In the ProgramData/Package Cache I still have more than one Postrgres125.msi and one postgreSQL.msi files.

Or
MVP
MVP

I realize this is a little too "Restart your PC" for comfort, but - did you check that there weren't any prompts waiting? I'm asking because in the past I've had the Qlik Sense installer pop up prompts under the installer window that weren't visible until I moved the installer window somewhere else, and that would behave the same as if the installer was stuck.

RikEr
Partner - Contributor II
Partner - Contributor II
Author

@Or Good question, but yes. It was one of the first things I did when I noticed that there was no progression anymore. Searching and looking if there was a prompt-window open.

So I moved the installer window around, I think it saw every corner of the screen, and even looking if there was any other window open by using the alt-tab-combi in windows. But there was none other than the installer window.

RikEr
Partner - Contributor II
Partner - Contributor II
Author

So after a few weeks and the last reboot and roll back of a backup we tried to upgrade to the november 2023 version again. And at exactly the same point during installation it got stuck again. So we again had to roll back to a back up.

What I don't understand is that during the installation no buttons are visible to cancel the installation at any point. In the step "installing repository database" where it got stuck I imagine that it needed something as a user and pwd for the postgres database but no window, nor any of that kind was seen. Not even at the start if the installation.

Only at the beginning of the installation I got an input-question for the installation user or services-user. After that nothing.

So leaving it at that for now, the question is if we can upgrade to the February 2024 version without upgrading to the November 2023 version. Do any of you know if that is possible? Thanks in advance.