Qlik Community

Deployment & Management

Discussion board where members learn more about Qlik Sense Installation, Deployment and Management.

Announcements
Support Case Portal has moved to Qlik Community! Read the FAQs to start exploring Support resources.
cancel
Showing results for 
Search instead for 
Did you mean: 
catalystmichael
Partner
Partner

Operations Monitor Missing from Governance Section of QMC

Reinstalled the Operations Monitor successfully but the app is not listed under the Governance section of the QMC.  With this being a QAP server the app can't be accessed via the hub, it has to be via the Governance link so that means that users have no access.

Any ideas as to why the app doesn't show in the Governance section?  The untouched Licence monitor is still there.

Thanks

Michael

4 Replies
awhitfield
Partner
Partner

Hi Michael,

Have you published it to the 'Monitoring Apps' stream?

Andy

catalystmichael
Partner
Partner
Author

Hi, yes it's in the stream.  When I go to the hub I can see it too (just can't access it because it's a QAP server).

Ken_T
Creator II
Creator II

did you ever figure this out?
same issue on a new env.

Bastien_Laugiero

Hello @Ken_T ,

The Monitoring Apps section usually disappear from the Governance menu in the QMC when the Montoring Apps stream is being removed/recreated. The reason is because the system expect the Monitoring Apps stream to have a specific hard coded ID which is "a70ca8a5-1d59-4cc9-b5fa-6e207978dcaf".

The solution to resolve this problem is to create a new Monitoring Apps stream with above ID directly in the QRS Database. 

Here are the steps:

insert into "Streams" values ('a70ca8a5-1d59-4cc9-b5fa-6e207978dcaf', 'Monitoring Apps',
current_timestamp,current_timestamp,'Internal\sa_repository',(select "ID" from "Users" where "Name" = 'sa_repository'))
  • At this point you should observe a new Monitoring Apps stream in the QMC with ID "a70ca8a5-1d59-4cc9-b5fa-6e207978dcaf" and the Monitoring Apps section should have reappeared under the Governance menu
  • Reimport the Operation and License Monitor in that new stream
  • Re-create the Monitoring Apps associated rules (see screenshots)

Note: Before doing that into a production system, I would highly suggest to test above steps into a lower environment. Also please make sure to take a backup of your database before running any command. 

Hope this helps!

 

Bastien Laugiero
If a post helps to resolve your issue, please mark the appropriate replies as CORRECT.