Qlik Community

Ask a Question

Deployment & Management

Discussion board where members learn more about Qlik Sense Installation, Deployment and Management.

Announcements
LINKEDIN LIVE: Democratizing data to enhance customer-centricity. JULY 29TH REGISTER TODAY
cancel
Showing results for 
Search instead for 
Did you mean: 
caiogil1
Contributor III
Contributor III

Qlik Sense - Unknown connection type

Hi,

I'm facing this issue after upgrade Qlik Sense to Sep 2020 Patch 3. Actually it began a short while after the upgrade, but suddenly it appeared to the data connections tab in the data load script page with a message "Unknown connection type: QvOdbcConnectorPackage.exe" (also QVRestConnector.exe) like bellow:

Capture.PNG

When I try to create another connection a I realized that there is like has no connectors available.

não aparece todos os conectores.PNG

 

Anyone faced this before or have any tips to fix that? Maybe reinstall connectors package?

I hope to learn a lot here and help if I can
1 Solution

Accepted Solutions
caiogil1
Contributor III
Contributor III
Author

Hi @Bastien_Laugiero ,

 

It was some problem with security level on the network/server, it was blocking the connectors from working properly. Maybe even deleting the .exe connectors. 

Security team just added some configurations to trust Qlik Connections and reinstalled the connectors. It's working again.

I hope to learn a lot here and help if I can

View solution in original post

4 Replies
Bastien_Laugiero

Hi, 

Do you have internet connectivity on your Qlik Sense server(s)?

I have seen this article solving this error message: https://support.qlik.com/articles/000024864

Hope this helps!

Bastien Laugiero
If a post helps to resolve your issue, please mark the appropriate replies as CORRECT.
caiogil1
Contributor III
Contributor III
Author

Hi @Bastien_Laugiero ,

 

It was some problem with security level on the network/server, it was blocking the connectors from working properly. Maybe even deleting the .exe connectors. 

Security team just added some configurations to trust Qlik Connections and reinstalled the connectors. It's working again.

I hope to learn a lot here and help if I can

View solution in original post

SureshbaabuAZ
Contributor
Contributor

Hello,

We are experiencing this issue on Feb 2020 Patch 2 version.  Would it be possible to share the following?

1. Config change details performed by the security team to trust the Qlik Connections

2. Steps to reinstall the connectors for Qliksense

 

Thank you,

Suresh

 

 

Security team just added some configurations to trust Qlik Connections and reinstalled the connectors. It's working again.

ISS83
Partner
Partner

Hi, 

we experienced the similar issue after upgrading to Qlik Sense February 2021 and for us it was the  "Unknown connection type: QvOdbcConnectorPackage.exe" error. This was caused by a missing  connector_sdk_module_obdc.js file in C:\Program Files\Common Files\Qlik\Custom Data\QvOdbcConnectorPackage\web\ folder. This can be verified by opening the console (F12) in Chrome while in Data Load Editor in Qlik and seeing if in the Console tab there is an error indicating the missing connector_sdk_module_obdc.js file. 

The solution was to copy that missing js file from another environment running the same Qlik Sense version and after that the connectors started working again normally. No idea what could have caused this though, since there were no errors or such during installation.