Skip to main content
Announcements
Qlik Connect 2024! Seize endless possibilities! LEARN MORE
cancel
Showing results for 
Search instead for 
Did you mean: 
pauljohansson
Creator III
Creator III

QlikSenseUtil Version Mismatch

I get version mismatch when restoring my backup with the QlikSenseUtil.exe. I have trippled-check that Ive have the same version on my Backup as the Qlik_Sense_setup.exe, which is May 2022.


I still get: version mismatch: Backup and restore is only supported on the same Qlik Sense version, code=-2146233088

Labels (2)
1 Solution

Accepted Solutions
Eugene_Sleator
Support
Support

Hi  @pauljohansson the QlikSenseUtility can be used to restore a DB. If you refer to this  article. Download the "Qlik Sense Util Readme.txt" the instructions are contained in that file. 

View solution in original post

10 Replies
Eugene_Sleator
Support
Support

Hi @pauljohansson  is the patch level of the back up installation and where you are trying to restore the same? You will receive an error is the patch levels do not match also. 

pauljohansson
Creator III
Creator III
Author

@Eugene_Sleator 

I want to restore my backup on a Clean machine. My backup is done for QlikSense May 2022 SR4.

Im placing the installation-file for QlikSense May 2022 in designated path when running the QlikSense Utility.

Do you mean that I need to add the Patch file as well and specify the destination for the patch-file while doing the restore?

br

Paul

 

 

Eugene_Sleator
Support
Support

Hi @pauljohansson  I mean if you back up from QlikSense May 2022 SR4. Then you must restore to QlikSense May 2022 SR4. 

pauljohansson
Creator III
Creator III
Author

I must be missing something here. The installation file does not include the patch, this is a seperate file.

I have:

  • a clean machine with no QlikSense installation
  • a complete backup done with the QlikSenseUtility from a QlikSense May 2022 SR4
  • the installation-file for QlikSense May 2022

Im a missing something to be able to do  use the QlikSenseUtility and restore the environment?

br

Paul

 

 

Eugene_Sleator
Support
Support

Hi @pauljohansson in this situation you should remove the patch from the installation before backing up the DB. 

Then on the clean server restore the DB.

pauljohansson
Creator III
Creator III
Author

Hej @Eugene_Sleator 

We have sheduled backup running weekly using the QlikSenseUtility. So every time we run the backup we should remove the patch on our environment? 

Or do you mean that in practice the QlikSenseUtility restore functionality isnt useful unless you always run the inital release?

br

Paul

Eugene_Sleator
Support
Support

Hi  @pauljohansson you mentioned  "The installation file does not include the patch, this is a seperate file".
If you are intending to install to a clean server. You can install Qlik Sense then install the required patch. At that point you can then restore the database from the backup you made. 

pauljohansson
Creator III
Creator III
Author

Hej @Eugene_Sleator 

Thanks for answering!

Can I still use the QlikSenseUtility if I want to restore on a Clean server? That is,

1) Install Qlik and patch to match with backup taken with QlikSenseUtility

2) Use QlikSenseUtility to restore

Or do you mean that if I want to restore on a Clean server and im running a patched Qlik I should not use the QlikSenseUtility as a restore tool?

br

Paul

Eugene_Sleator
Support
Support

Hi  @pauljohansson the QlikSenseUtility can be used to restore a DB. If you refer to this  article. Download the "Qlik Sense Util Readme.txt" the instructions are contained in that file.