Skip to main content
Announcements
You can succeed best and quickest by helping others to succeed. Join the conversation.
cancel
Showing results for 
Search instead for 
Did you mean: 
Anonymous
Not applicable

Namespace not seen in .NET SDK

Hi All,

I have created a C# project with my VS2017 15.7.2.

I tried both the QlikSense.NetSDK  ver13.4.2 and 13.3.0, and I downloaded them through NuGet Package Manager in VS.

I tried with target framework 4.0 and 4.5.1.

However, my VS seems cannot find the namespaces, e.g. Qlik.Engine, Qlik.Sense, etc.

Ironically, the referenced dependencies are included and is usable, e.g. Autofac.

Is there any special settings that I have missed?

Thanks very much.

1 Reply
Anonymous
Not applicable
Author

I figured out that I have to include (Add Reference) the downloaded *.dll files before using the class library.

* Not to mention that this is the ONLY library IN THE WORLD that requires an EXTRA step to make it ready for use, which UNLIKE OTHERS.

However, it seems that I still need QvxLib and QvxLib.Connector for use.
I continue download them through NuGET, the QvxLib.Connector requires QvxLib to be installed before it could be installed.
While ALL libraries, including QvxLib itself, can reference to the dependent libraries and automatically download all required libraries, such as NLog and Autofuc for QvxLib's example; QvxLib.Connect fails to reference to its sibling product, QvxLib.

There is only QvxLib.dll file in the two packages, i.e. QvxLib.1.0.4 and QvxLib.Connector.1.0.2.3.
Whereas, the adding QvxLib.dll to the VS project did not make any change.

Still, the namespace `QvxView` is not correctly included / loaded as expected.

So, my question is: What is the actual correct way to include those library into a VS project?

Thanks.