Skip to main content

Integration, Extension & APIs

Discussion board where members can learn more about Integration, Extensions and API’s for Qlik Sense.

Announcements
CUSTOMERS ONLY: Now accepting customer applications for the 2023 Luminary Program: SUBMIT NOW
cancel
Showing results for 
Search instead for 
Did you mean: 
timsworldroamer
Partner - Contributor III
Partner - Contributor III

Qlik Sense and AngularJS

Are there currently plans to upgrade the version of AngularJS used in Qlik Sense to Angular2?

1 Solution

Accepted Solutions
Aiham_Azmeh
Employee
Employee

Hi timsworldroamer3‌,

Short answer: there no such plan

Similar thread: Qliksense - Angular 2 (Typescript)

View solution in original post

3 Replies
Aiham_Azmeh
Employee
Employee

Hi timsworldroamer3‌,

Short answer: there no such plan

Similar thread: Qliksense - Angular 2 (Typescript)

dale_ackerman
Contributor II
Contributor II

Well I am not sure that is a satisfactory answer.  My organization has everything from Angular 1.5 - 2/4 and React.JS  This is not good.  What is going to be the official best practice for integrations?  Why would you go ALL IN on angular and not have plans to keep it current?  Just saying...

Francis_Kabinoff
Former Employee
Former Employee

If you are using Angular 1.5, you can hook into the Angular instance that Qlik Sense uses. If you are using Angular 2 or React, you can simply use them, Angular 1 does not conflict with Angular 2 or React. You can also use something like enigma.js to get your data from the engine, with all the associative functionality, and use d3 or a more top-level charting library to build your charts. Your only real issues would be if you wanted to embed Qlik charts, and use a different version of Angular 1 than Qlik uses, in which case you could use iFrames for the Qlik charts.