Qlik Community

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Coming Aug. 9: New Simplified Authoring for Qlik Sense SaaS – For Details, CLICK HERE
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

How to disable automatic TRIM?

My question is very simple - how to disable an automatic trim in script?

For example - when I have in my SQL table in two rows such data: "12345" and " 12345" (in second variant there is a space before the number) - all I have in Qlik in both rows - is "12345". Whether I use text(Field) or just a Field - any way Qlik trims spaces.

How to disable it?

1 Solution

Accepted Solutions
johnw
Champion III
Champion III

There's a special variable for it, "Verbatim".

SET Verbatim = 1; // This stops the auto trim for anything following it in the script
SET Verbatim = 0; // This restarts the auto trim for anything following it in the script

View solution in original post

3 Replies
johnw
Champion III
Champion III

There's a special variable for it, "Verbatim".

SET Verbatim = 1; // This stops the auto trim for anything following it in the script
SET Verbatim = 0; // This restarts the auto trim for anything following it in the script

Not applicable
Author

thnx

bumin
Creator II
Creator II

it didn't work on my app

anythink else to check?