Skip to main content
Announcements
Qlik Introduces a New Era of Visualization! READ ALL ABOUT IT
cancel
Showing results for 
Search instead for 
Did you mean: 
Anonymous
Not applicable

Current Selections Display Issue

In the application, I have a standard current selections box. My problem is that users do not like when they select all but a few, or all the values in a field that the current selections box will display "NOT value, value, value" or "ALL".

I've attached an image of issue if the above explanation or example below is not clear.

Does anyone know how I can make it so that if they make selections in a field (let's say Month) with the values equal to everything but one that it will show every value selected rather than NOT value? Is this possible?

EXAMPLE:

Field = Month

Values = Jan, Feb, Mar, Apr, May, Jun, Jul, Aug, Sep, Oct, Nov, Dec

User selections in field = Jan, Feb, Mar, Apr, May, Jun, Jul, Aug, Sep

Display in Current Selections box = "NOT Oct, Nov, Dec"

Desired Display in Current Selections box = "Jan, Feb, Mar, Apr, May, Jun, Jul, Aug, Sep"

Thanks!

1 Solution

Accepted Solutions
Anonymous
Not applicable
Author

Well, there is nothing you can do on the Current Selection object itself.  But you can do something for pdf printing.

In the print dialog, go to Header/Footer.  Here you can use any section of header or footer for your purpose, just enter something like this:

='Months: ' & GetFieldSelections(Month, '; ', 12)

And, click "Save Settings" so you don't need to do it every time.

Regards,

Michael

View solution in original post

7 Replies
Anonymous
Not applicable
Author

Try to increas "Max Values in Current Selections" in User Preferences.  Keep in mind thta it is a property of user environment, not of QV application.

Another approach - use text box instaed, with functions getfieldselections()

Regards,

Michael

Anonymous
Not applicable
Author

Thank you. I was reviewing my post right before your reply when I noticed this discussion in the "More Like This" window...http://community.qlik.com/message/227838#227838

This works great and is exactly what I was looking for .... but it doesn't appear to function for applications opened from a server deployment.

Am I doing something wrong or is this a limitation?

Thanks!

Anonymous
Not applicable
Author

I tried using the getfieldselections() and getcurrentselections() in a text box prior and it showed the same (reduced) display of selected values in a field(s).....is there a parameter that can be set with either of these functions which will change the output (like the max values in current selections property does)?

Anonymous
Not applicable
Author

Ok I looked up the help file and saw that there is a parameter to set the max values for the functions used in list box - which does work even in server deployments.....

Still interested in knowing if there is a way to include this feature for the current selections object. The objective for users is to include it in when they print a chart object (to excel or pdf) where all the values are displayed.

Anonymous
Not applicable
Author

Well, there is nothing you can do on the Current Selection object itself.  But you can do something for pdf printing.

In the print dialog, go to Header/Footer.  Here you can use any section of header or footer for your purpose, just enter something like this:

='Months: ' & GetFieldSelections(Month, '; ', 12)

And, click "Save Settings" so you don't need to do it every time.

Regards,

Michael

Anonymous
Not applicable
Author

Thanks, Michael! This works great!

I appreciate your helpful input.

rajan_07kumar
Partner - Contributor III
Partner - Contributor III

In my case there were multiple login ids coming up. Instead of showing the selected value 'abc@google.com' the current selections box was showing "NOT def@google.com, ghi@google.com, fjk@google.com etc"

In case you are having section access in your script make sure the section access fields are matching in values and casing. 

In my case section access script had the NTNAME(username) in small letters and the login table had the NTNAME in capital letters.

This worked in my case