Skip to main content
Qlik Connect 2024! Seize endless possibilities! LEARN MORE
Showing results for 
Search instead for 
Did you mean: 
4 Replies
Partner Ambassador
Partner Ambassador

Hi, is anyone running into issues with trying to setup kubernetes on Minikube? 

I've tried doing configuring QSE on Minikube via the Qlik Help file, which was unsuccessful, and now after watching the youtube video and using some scripts from GitHub (, I am getting the same problem:

It seems that when Helm is started, Tiller isn't being initialised correctly, so when you run <helm install>, you get an error re "Could not find Tiller"


$HELM_HOME has been configured at C:\Users\<name>\.helm.
Error: error installing: the server could not find the requested resource
Error: could not find tiller
Error: could not find tiller
No resources found in default namespace.

There are posts online re this issue, and I've tried a few of them, i.e. rolling back my version of Kubernetes, but, this doesn't resolve. I am not really sure where to go next, as my knowledge of this world is quite slim, hence why wondering if anyone else in the Qlik world is having this issue? 

Former Employee
Former Employee

Hi @Carl_Hunter ,

I haven't used that PS script myself to deploy, but what you need to check first is that kubectl is set up to work against minikube.

If you run kubectl config get-contexts you should get something similar to:

k8s-3tier k8s-3tier k8s-3tier-admin
microk8s-cluster microk8s-cluster microk8s-admin
* minikube minikube minikube
minishift 192-168-99-100:8443 developer/192-168-99-100:8443

Make sure kubectl is configured to work against minikube (the * at the beginning).

If not, run the following:

kubectl config use-context minikube

Check communication is working using:

kubectl cluster-info

This should give you the following:

Kubernetes master is running at
KubeDNS is running at


As Helm is using kubectl it's essential that kubectl is configured and working properly before trying to initialize Helm and deploy the tiller pod.

Since v0.26 of minikube RBAC is enabled by default. You can check this by running:

kubectl api-versions

If you have the following line,, you need to add a service account for tiller before deploying it, as described here:

I hope the above solves your issues.



Partner Ambassador
Partner Ambassador

Hi @Bjorn_Wedbratt @Troy_Raney 

Sorry, this still isnt working after I've applied the service account to teller. I keep getting an error when running helm init:

Error: error installing: the server could not find the requested resource

The Qlik Help file doesn't really go into that much detail re Minikube, which is disappointing (

Former Employee
Former Employee

Hi @Carl_Hunter 

I investigated this a bit further and there seems to be an issue with Helm and Kubernetes 1.16 when running minikube as discussed here:

I tried to downgrade kubernetes to 1.15 and that seems to be the easiest workaround for now.

What you need to do is:

delete the existing deployment of minikube

minikube delete

Then if you look into the 1-Deploy-Minikube-Win.ps1, edit the line where minikube is started and specify the version

minikube start --memory $VmMemory --cpus=$VmCpu --kubernetes-version=1.15.4

Now everything should be working fine.