Qlik Community

Ask a Question

Deployment Framework

Announcements
Support Cases coming to Qlik Community Oct. 4! Start chats, open cases, explore resources. READ DETAILS>
cancel
Showing results for 
Search instead for 
Did you mean: 
fernando_tonial
Partner
Partner

Variable not working

Hello, When I go to create the variable, I select the container and create the variable, but the update appears in the Home. I can not use this variable in my project. See image.

Error QDF.png

Best Regards.

Tonial.

1 Solution

Accepted Solutions
Magnus_Berg
Employee
Employee

Hi Again Fernando, we did not find any problems with the current Variable Editor, it could be a issue with a early 1.4.0 release. Try the attached Variable Editor (replace the old).

Best regards

View solution in original post

13 Replies
Magnus_Berg
Employee
Employee

Hi Fernando, Thanks for the information we will have a look and search for possible bugs during this week, we will let you know.

Best regards

Magnus

Magnus_Berg
Employee
Employee

Hi Again Fernando, we did not find any problems with the current Variable Editor, it could be a issue with a early 1.4.0 release. Try the attached Variable Editor (replace the old).

Best regards

View solution in original post

carvalguil
Contributor III
Contributor III

Hello,

I'm facing the same issue. When I select any container other than "Admin", the variable vL.BaseVariablePath is always filled with the "Admin" base path.

If I reload manually the qvw again by Ctrl + R, then the variable gets the correct base path. So I've added a second line "ActiveDocument.ReloadEX 1,1" in the macro Sub Reload. This way forcing the second reload and fixing my problem.

This is not a good way to fix it, but I don't have enough time now to understand if (and why) this is happening on script level. That script is really complex .

So I leave here my exerience. Maybe this can be a clue to find the real reason.

Best Regards,

Guilherme Carvalho

kevpickering
Contributor III
Contributor III

I'm also getting the same problem with editing variables.

I downloaded your attached updated release 1.4.0 Variable editor, but when I run it, after a few seconds, I get the 'Execution of script failed. Reload old data? Yes/No' popup. After clicking yes (or no), the app closes.

We're running QlikView version 10 SR6 64-bit edition and the variable editor is located on the network not locally.

Magnus_Berg
Employee
Employee

Hi Kevin, do you have UAC activated? Variable Editor need to run as Administrator.
See this thread http://community.qlik.com/thread/118776

Hope this helps

Magnus

kevpickering
Contributor III
Contributor III

Yes UAC is activated. The older version runs ok by simply executing the qvw but doesn't function correctly (same problem as Fernando in the original post).

The new version just won't run, apart from the 'Execution of script failed' popup.

I have also tried starting QlikView with 'Run As Administrator', opened the new Variable Editor, and still it won't run apart from the pop up.

Magnus_Berg
Employee
Employee

Kevin, could you try QlikView 11.2 instead of 10? You can just copy the QlikView 11 program folder from another computer or vm if you don't want to uninstall v10.

Cheers

kevpickering
Contributor III
Contributor III

Due to the enterprise I'm working within, being able to upgrade is not in my control.

However, I do have Version 11 SR8 (most up to date) on my BYOD (Surface Pro 2). I downloaded the Variable Editor and placed in the Administration container. On executing for the first time it asked for System Access which I allowed. Then the pop up 'Execution of script failed' appeared. Each subsequent time I execute the Variable Editor, the pop up appears. It is not working.

The old version of Variable editor runs ok when I reinstall it.

Magnus_Berg
Employee
Employee

  • It could be that you are using an older QDF version and some sub function updates are missing. But you can still use your old Variable Editor there are very minor changes between versions.

  • Also check out the ContainerMap.csv and CustomVariables.csv (that is stored under 0.Administration\3.Include\1.BaseVariable) so that they don't contain any errors/strange characters.

  • And Variable Editor must be stored under 0.Administration\6.Script\2.VariableEditor

Hope this helps