Skip to main content

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
QlikWorld 2023, a live, in-person thrill ride. Save $300 before February 6: REGISTER NOW!
cancel
Showing results for 
Search instead for 
Did you mean: 
999rs
Contributor
Contributor

Data load from cte - Error

Hi, using qlik sense.  After  update to 2019 feb release i am getting errors in my data load tasks. (Connector reply error: Executing non-SELECT queries is disabled. Please contact your system administrator to enable it.)

According to this articles (https://help.qlik.com/en-US/connectors/Subsystems/ODBC_connector_help/Content/Connectors_ODBC/How-to... and https://support.qlik.com/articles/000064538 ) I have to change  "allow-nonselect-queries" setting to true in my QvOdbcConnectorPackage.exe.config file

But my QvOdbcConnectorPackage.exe.config file does not contain   "allow-nonselect-queries" property.

I am asking for example of  QvOdbcConnectorPackage.exe.config  with "allow-nonselect-queries" enabled.

here is my current content of QvOdbcConnectorPackage.exe.config :

<?xml version="1.0"?>
<configuration>
    <configSections>
        <sectionGroup name="userSettings" type="System.Configuration.UserSettingsGroup, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089">
            <section name="QvOdbcConnector.Properties.Settings" type="System.Configuration.ClientSettingsSection, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" allowExeDefinition="MachineToLocalUser" requirePermission="false"/>
        </sectionGroup>
    </configSections>
    <userSettings>
        <QvOdbcConnector.Properties.Settings>
            <setting name="LoggingLevel" serializeAs="String">
                <value>ERROR</value>
            </setting>
        </QvOdbcConnector.Properties.Settings>
    </userSettings>
<startup>
  <supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.5.2"/>
</startup>
  <appSettings>
    <add key="InstallationMode" value="Enterprise" />
  </appSettings>
</configuration>

 

Labels (3)
1 Solution

Accepted Solutions
qlikdan
Contributor II
Contributor II

I have been having the same problem too. The config property is under the <appSettings> section near the bottom of the file. Add a row like "<add key="allow-nonselect-queries" value="true" />" so your config file would read:

<appSettings>
<add key="allow-nonselect-queries" value="true" />
<add key="InstallationMode" value="Enterprise" />
</appSettings>

 

View solution in original post

2 Replies
999rs
Contributor
Contributor
Author

Can any body help? just reply with correct config part with "allow-nonselect-queries" setting
qlikdan
Contributor II
Contributor II

I have been having the same problem too. The config property is under the <appSettings> section near the bottom of the file. Add a row like "<add key="allow-nonselect-queries" value="true" />" so your config file would read:

<appSettings>
<add key="allow-nonselect-queries" value="true" />
<add key="InstallationMode" value="Enterprise" />
</appSettings>