Qlik Community

Ask a Question

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Support Cases coming to Qlik Community Oct. 4! Start chats, open cases, explore resources: READ DETAILS
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Pivot table dimensions not showing up in server?!

Good Afternoon,

I have finished creating a small application we have and it has a single pivot table with two dimensions and about 15 expressions.

Since we have so many expressions I decided to flip the table 90 degrees and have the dimensions on top Y axis, and the expressions on the X axis. I have done so by simply dragging the cells and realigning. It looks great when on my development machine.

I push this application to the server and now suddenly it is ignoring one of the dimensions. I am confused as to what might be causing this!?

EDIT: Note that when I tried to remove the dimension that was working, so only one dimension was left the table appeared in the server with no dimensions.

EDIT 2: I had suppress when value is null on that main dimension, when i removed it I could see the missing dimension, but ONLY when one dimension is selected. Suspecting that has something to do with it.

Edit 3: I now have it working, but it is really weird, I had to select "Show all values" on both dimensions to get it to work. Can someone explain if that's the expected behavior?!

Note that this is still open as the fix only worked in the QA Environment and not Prod... inconsistent behavior.

0 Replies