Qlik Community

Ask a Question

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Our next Qlik Insider session will cover new key capabilities. Join us August 11th REGISTER TODAY
cancel
Showing results for 
Search instead for 
Did you mean: 
martynlloyd
Partner
Partner

iSeries Connection problem

Hi, I have two AS/400 iSeries: DEV and PROD

I use almost identical connection strings, but the CCSID translate does not work for the DEV machine

On the PROD box I use connection string:

OLEDB CONNECT32 TO [Provider=IBMDASQL.DataSource.1;Persist Security Info=True;User ID=KPITRANS;Data Source=dafehvuk400;Protection Level=None;Extended Properties="";Transport Product=Client Access;SSL=DEFAULT;Force Translate=65535;Default Collection=KPITRANS;Convert Date Time To Char=TRUE;Catalog Library List="";Cursor Sensitivity=3;Use SQL Packages=False;SQL Package Library Name="";SQL Package Name="";Add statements to SQL package=True;Unusable SQL Package Action=1;Block Fetch=True;Data Compression=True;Sort Sequence=0;Sort Table="";Sort Language ID="";Query Options File Library="";Trace=0;Hex Parser Option=0;Maximum Decimal Precision=31;Maximum Decimal Scale=31;Minimum Divide Scale=0;Library List="";Naming Convention=0;Query Optimize Goal=0;Query Storage Limit=-1;Handle Numeric Data Errors=1;Keep Trailing Blanks=False;Application Name=QvConnect32.EXE;Decfloat Rounding Mode=0;Decfloat Error Option=0;Client User ID="";Client WorkStation Name="";Client Program ID="";Client Accounting="";Block Size=0;Concurrent Access Resolution=0;Xml Strip Whitespace=True];

PERFECT, works a treat!

But on DEV box I use

OLEDB CONNECT32 TO [Provider=IBMDASQL.DataSource.1;Persist Security Info=False;User ID=mlloyd;Data Source=10.160.28.71;Protection Level=None;Extended Properties="";Initial Catalog=NEWDEV;Transport Product=Client Access;SSL=DEFAULT;Force Translate=65535;Default Collection=MLLOYD;Convert Date Time To Char=TRUE;Catalog Library List="";Cursor Sensitivity=3;Use SQL Packages=False;SQL Package Library Name="";SQL Package Name="";Add statements to SQL package=True;Unusable SQL Package Action=1;Block Fetch=True;Data Compression=True;Sort Sequence=0;Sort Table="";Sort Language ID="";Query Options File Library="";Trace=0;Hex Parser Option=0;Maximum Decimal Precision=31;Maximum Decimal Scale=31;Minimum Divide Scale=0;Library List="";Naming Convention=0;Query Optimize Goal=0;Query Storage Limit=-1;Handle Numeric Data Errors=1;Keep Trailing Blanks=False;Application Name=QvConnect32.EXE;Decfloat Rounding Mode=0;Decfloat Error Option=0;Client User ID="";Client WorkStation Name="";Client Program ID="";Client Accounting="";Block Size=0;Concurrent Access Resolution=0;Xml Strip Whitespace=True];

Data is arriving as EBCDIC instead of ASCII

Can anyone help?

Regards, Marty.

1 Solution

Accepted Solutions
martynlloyd
Partner
Partner
Author

I solved the issue by changing

Force Translate=65535

to

Force Translate=37

Marty.

View solution in original post

1 Reply
martynlloyd
Partner
Partner
Author

I solved the issue by changing

Force Translate=65535

to

Force Translate=37

Marty.

View solution in original post