Improving Image Quality Export using Clipboard Zoom

    Greetings,

     

    For the longest time, I have been trying to improve the quality of an exported image out of Qlikview.  Sometimes my end users want to just copy an image to the clipboard and paste it into an e-mail or a Word document.  By default these images export with less than desirable quality.  In particular, I use Nprinting and the image quality was so poor, we almost could not use the application.

     

    Well, sometime a blind squirrel finds a nut or in my case the lottery ticket that wins you a millions dollars.

     

    There is a setting in the User Preferences in Qlikview called Clipboard Zoom.  See attached Word Document.  By default, this setting is at 100 % in order to minimize the file size of the output.  This also leads to less than desirable quality.  I included an image from the sample surgical dashboard at 100 %.  I then change the setting to 400 % and copied the image to the clipboard and pasted the same image to the Word document   The results are astounding.  If you view the 400 % file, you can enlarge it and still get good quality.  The only sacrifice is that the file size of the image is substantially bigger.  I will gladly trade file size for image quality.

     

    Try zooming on the images in the Word document.  It is night and day difference.

     

    Now, here is the tricky part.  The setting is a User Preference.   So, even if I change it on my developers machine, I need to make sure the setting is changed on my end users desktop client.   If you are using Nprinting, you can specify the user name and password when you are connecting to the source data.

     

    As a general rule, you should probably size your objects in Qlikview about the same size that you would like to appear in your external document after you export it.  This will minimize possible distortion as you scale it further.

     

    I hope this post is helpful for you today.

     

    Mike Czerwonky

    BI Developer